Proxmox VE

Install Open vSwitch

Update the package index and then install the Open vSwitch and ifupdown2 packages by executing:

apt update
apt install ifupdown2
apt install openvswitch-switch

NOTE: In the version of Proxmox we are using, the package ifupdown2 is installed. Why is that important? Originally in Debian you have to reboot the whole server in order to apply changes to network settings. The ifupdown2 package allows us to apply changes without the reboot.

Before edit /etc/network/interfaces, please backup this file.

cp /etc/network/interfaces /etc/network/interfaces.backup

Editing:

vi /etc/network/interfaces

File:

auto lo
iface lo inet loopback
 
auto enp1s0
iface enp1s0 inet manual
 
auto enp2s0
iface enp2s0 inet manual
 
auto enp3s0
iface enp3s0 inet manual
 
auto enp4s0
iface enp4s0 inet manual
 
auto enp5s0
iface enp5s0 inet manual
 
auto enp6s0
iface enp6s0 inet manual
 
auto vlan1
iface vlan1 inet static
        address 192.168.88.4/24
        gateway 192.168.88.1
        ovs_type OVSIntPort
        ovs_bridge vmbr0
        ovs_options vlan_mode=access
        ovs_extra set interface ${IFACE} external-ids:iface-id=$(hostname -s)-${IFACE}-vif
        dns-nameservers 192.168.88.1 8.8.8.8 8.8.4.4
 
auto bond0
iface bond0 inet manual
        ovs_bonds enp1s0 enp2s0 enp3s0 enp4s0 enp5s0
        ovs_type OVSBond
        ovs_bridge vmbr0
        ovs_options vlan_mode=native-untagged bond_mode=balance-slb
 
auto vmbr0
iface vmbr0 inet manual
        ovs_type OVSBridge
        ovs_ports bond0 vlan1

Apply:

ifreload -a
ifup vmbr0

RouterOS

/interface bridge port
remove [ find interface=ether1 ]
remove [ find interface=ether2 ]
remove [ find interface=ether3 ]
remove [ find interface=ether4 ]
remove [ find interface=ether5 ]

To move to the top level again, type ” / “

/interface bonding add mode=balance-alb slaves=ether1,ether2,ether3,ether4,ether5 primary=ether1 name=bond1
/interface bridge port
add bridge=bridge interface=bond1

Reference List

  1. https://mp.weixin.qq.com/s?__biz=Mzg4Mjg4NjYwNg==&mid=2247484026&idx=1&sn=bd6a7418fcd5b871332555aa3af8d407&chksm=cf4e90dbf83919cd4d870567de6c4817ae89514b0395db475bcecd01b0bf8a08f1b928aed4e3&mpshare=1&scene=1&srcid=1207rkFK4JLNRmkr0RYuCYkV&sharer_shareinfo=da8a1857bf7a67e2adcad1ec6d2b3f29&sharer_shareinfo_first=da8a1857bf7a67e2adcad1ec6d2b3f29&exportkey=n_ChQIAhIQIZVS%2Bd9hvuanqVYOXIccnRKWAgIE97dBBAEAAAAAABYUGYni0kAAAAAOpnltbLcz9gKNyK89dVj0hC2gvZTZzEgbwFYAg43oA%2Fww4jGfSl1%2FAfJRZYdPETpfnkLsBwAU7qVd4tc5LYhgBfG3Z7tVK6oVSwziVnJgcZLUz4gy2sz5Gk1WpF5Z2oW92L%2B9syuGaIu5nvsOsVQPKsFcay5qQoCTASQYkfO5cG2%2FVun%2BYqxeGMwTaP4zz1T%2Fh8DpBdrY0HsJjpsekVAMNltzePe9sTTzjp%2Fo9Je0gDVHqA%2Bm78cuEmL5sjQnRzXYjbUrfmdbwEtAZhFEOCW%2BQYa%2BR0RaLgT5WAE0AEtcPuueaYnlyRd9AKuXSXaxsGk7svMyaV95fPBOOjAhhos9&acctmode=0&pass_ticket=1%2BYiiSKYScCouAi1%2B59Z25fG%2BK%2B3RiKA0SqdRJVrvZmvpKnsLZlvjBt2RTgl3JcTp%2F%2BepdT%2FDTt1bnY3ddraog%3D%3D&wx_header=0#rd
  2. https://docs.openvswitch.org/en/latest/topics/bonding/
  3. https://karneliuk.com/2021/08/infrastructure-1-building-virtualized-environment-with-debian-linux-and-proxmox-on-hp-and-supermicro/